Segmentation fault when trying to run capacitor example

I tried to run capacitor simulation after I built devsim on Fedora. But I am getting segmentation fault during solve function execution. I tried to find the reason by looking into the code. It seems to me that segmentation fault occurs when running itermethod.solve in Although I want to mention that when I try to directly use devsim library(pre-built) from the release page, it seems to run fine.

Figured out the issue. I was using a newer version of SuperLU. So, correspondingly I had to make changes to conform to the newer API which I did, and now it is working fine.

Welcome @gsomani!

Thank you for your investigation. Please create a pull request with your changes and I will incorporate them in a future release. It would be nice to have a newer version of SuperLU in the software.

I have raised a pull request. Other thing which I found was that there was no cmake file for fedora. I struggled with that. So, I can add cmake for fedora also in the pull request if required. I am using fedora and am using installed packages under dnf. So, my SuperLU 5.3 comes from dnf install.

1 Like

Thanks for your contribution. It is now on the r1.6.1 branch